import re
regex = re.compile(r"<p class=\"text_obisnuit\">(?:(?!<\/p>)(?!<p).)*(?:<.+?>|\z)", flags=re.MULTILINE)
test_str = ("<p class=\"text_obisnuit\"><em>I have to make sure of that</em></p>\n\n"
"<p class=\"text_obisnuit\"><em>I have to make sure of that</em><br>\n"
"<p class=\"text_obisnuit\">I have to make sure of that</div>\n"
"<p class=\"text_obisnuit\">I have to make sure of that\n"
"</div>\n\n"
"Toto, I have to select all lines that do not end with </p>\n\n"
"your regex <p class=\"TEXT\">(?:(?!<br>)(?!<p).)*(?:<.+?>|\\z)\n\n"
"becomes in this case:\n\n"
"<p class=\"text_obisnuit\">(?:(?!<\\/p>)(?!<p).)*(?:<.+?>|\\z)\n\n"
"I think I made a mistake somewhere")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")