re = /<p class="text_obisnuit">(?:(?!<\/p>)(?!<p).)*(?:<.+?>|\z)/m
str = '<p class="text_obisnuit"><em>I have to make sure of that</em></p>
<p class="text_obisnuit"><em>I have to make sure of that</em><br>
<p class="text_obisnuit">I have to make sure of that</div>
<p class="text_obisnuit">I have to make sure of that
</div>
Toto, I have to select all lines that do not end with </p>
your regex <p class="TEXT">(?:(?!<br>)(?!<p).)*(?:<.+?>|\\z)
becomes in this case:
<p class="text_obisnuit">(?:(?!<\\/p>)(?!<p).)*(?:<.+?>|\\z)
I think I made a mistake somewhere'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end