using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<p class=""text_obisnuit"">(?:(?!<\/p>)(?!<p).)*(?:<.+?>|\z)";
string input = @"<p class=""text_obisnuit""><em>I have to make sure of that</em></p>
<p class=""text_obisnuit""><em>I have to make sure of that</em><br>
<p class=""text_obisnuit"">I have to make sure of that</div>
<p class=""text_obisnuit"">I have to make sure of that
</div>
Toto, I have to select all lines that do not end with </p>
your regex <p class=""TEXT"">(?:(?!<br>)(?!<p).)*(?:<.+?>|\z)
becomes in this case:
<p class=""text_obisnuit"">(?:(?!<\/p>)(?!<p).)*(?:<.+?>|\z)
I think I made a mistake somewhere";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}