const regex = /<p class="text_obisnuit">(?:(?!<\/p>)(?!<p).)*(?:<.+?>|\z)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<p class="text_obisnuit">(?:(?!<\\\/p>)(?!<p).)*(?:<.+?>|\\z)', 'gm')
const str = `<p class="text_obisnuit"><em>I have to make sure of that</em></p>
<p class="text_obisnuit"><em>I have to make sure of that</em><br>
<p class="text_obisnuit">I have to make sure of that</div>
<p class="text_obisnuit">I have to make sure of that
</div>
Toto, I have to select all lines that do not end with </p>
your regex <p class="TEXT">(?:(?!<br>)(?!<p).)*(?:<.+?>|\\z)
becomes in this case:
<p class="text_obisnuit">(?:(?!<\\/p>)(?!<p).)*(?:<.+?>|\\z)
I think I made a mistake somewhere`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}