using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<ambiente>\w*)[-_](?<app>\w*)[-_](?<hospital>\w*)[-_](?<database>\w*)?[-_](?<schema>\w*)?[-_](?<table>\w*)";
string input = @"HML_HIS_WPD_TL_RDSL_SMART_MOVIMENTO_PAC
HML_HIS_T_INTPD_KAFKA_ALERGIA
{environment}-{application}-{hospital}-{databaseName}-{schemaName}-{tableName}
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}