import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<ambiente>\\w*)[-_](?<app>\\w*)[-_](?<hospital>\\w*)[-_](?<database>\\w*)?[-_](?<schema>\\w*)?[-_](?<table>\\w*)";
final String string = "HML_HIS_WPD_TL_RDSL_SMART_MOVIMENTO_PAC\n"
+ "HML_HIS_T_INTPD_KAFKA_ALERGIA\n\n"
+ "{environment}-{application}-{hospital}-{databaseName}-{schemaName}-{tableName}\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}