const regex = /(?<ambiente>\w*)[-_](?<app>\w*)[-_](?<hospital>\w*)[-_](?<database>\w*)?[-_](?<schema>\w*)?[-_](?<table>\w*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<ambiente>\\w*)[-_](?<app>\\w*)[-_](?<hospital>\\w*)[-_](?<database>\\w*)?[-_](?<schema>\\w*)?[-_](?<table>\\w*)', 'gm')
const str = `HML_HIS_WPD_TL_RDSL_SMART_MOVIMENTO_PAC
HML_HIS_T_INTPD_KAFKA_ALERGIA
{environment}-{application}-{hospital}-{databaseName}-{schemaName}-{tableName}
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}