package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<ambiente>\w*)[-_](?<app>\w*)[-_](?<hospital>\w*)[-_](?<database>\w*)?[-_](?<schema>\w*)?[-_](?<table>\w*)`)
var str = `HML_HIS_WPD_TL_RDSL_SMART_MOVIMENTO_PAC
HML_HIS_T_INTPD_KAFKA_ALERGIA
{environment}-{application}-{hospital}-{databaseName}-{schemaName}-{tableName}
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}