re = /(?<ambiente>\w*)[-_](?<app>\w*)[-_](?<hospital>\w*)[-_](?<database>\w*)?[-_](?<schema>\w*)?[-_](?<table>\w*)/m
str = 'HML_HIS_WPD_TL_RDSL_SMART_MOVIMENTO_PAC
HML_HIS_T_INTPD_KAFKA_ALERGIA
{environment}-{application}-{hospital}-{databaseName}-{schemaName}-{tableName}
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end