// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?<ambiente>\w*)[-_](?<app>\w*)[-_](?<hospital>\w*)[-_](?<database>\w*)?[-_](?<schema>\w*)?[-_](?<table>\w*)").unwrap();
let string = "HML_HIS_WPD_TL_RDSL_SMART_MOVIMENTO_PAC
HML_HIS_T_INTPD_KAFKA_ALERGIA
{environment}-{application}-{hospital}-{databaseName}-{schemaName}-{tableName}
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}