using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(org-)?foo.dev.(en|ru)?(\.)?domain.(com.au|com)";
string input = @"org-foo.dev.en.domain.com.au
foo.dev.domain.com.au
foo.dev.en.domain.com.au
org-foo.dev.en.domain.com.au
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}