import re
regex = re.compile(r"(org-)?foo.dev.(en|ru)?(\.)?domain.(com.au|com)", flags=re.MULTILINE)
test_str = ("org-foo.dev.en.domain.com.au\n"
"foo.dev.domain.com.au\n"
"foo.dev.en.domain.com.au\n"
"org-foo.dev.en.domain.com.au\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")