$re = '/(org-)?foo.dev.(en|ru)?(\.)?domain.(com.au|com)/m';
$str = 'org-foo.dev.en.domain.com.au
foo.dev.domain.com.au
foo.dev.en.domain.com.au
org-foo.dev.en.domain.com.au
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);