import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(org-)?foo.dev.(en|ru)?(\\.)?domain.(com.au|com)";
final String string = "org-foo.dev.en.domain.com.au\n"
+ "foo.dev.domain.com.au\n"
+ "foo.dev.en.domain.com.au\n"
+ "org-foo.dev.en.domain.com.au\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}