// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(org-)?foo.dev.(en|ru)?(\.)?domain.(com.au|com)").unwrap();
let string = "org-foo.dev.en.domain.com.au
foo.dev.domain.com.au
foo.dev.en.domain.com.au
org-foo.dev.en.domain.com.au
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}