const regex = /(org-)?foo.dev.(en|ru)?(\.)?domain.(com.au|com)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(org-)?foo.dev.(en|ru)?(\\.)?domain.(com.au|com)', 'gm')
const str = `org-foo.dev.en.domain.com.au
foo.dev.domain.com.au
foo.dev.en.domain.com.au
org-foo.dev.en.domain.com.au
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}