re = /(org-)?foo.dev.(en|ru)?(\.)?domain.(com.au|com)/m
str = 'org-foo.dev.en.domain.com.au
foo.dev.domain.com.au
foo.dev.en.domain.com.au
org-foo.dev.en.domain.com.au
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end