#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)<input[^>]*\s*(?=[^>]*type\s*=\s*('|"|)Submit\s*(\1))[^>]*\s*(?:value\s*=('|"|)Next\s*(\3))[^>]*>"
Local $sString = "<input name="daily" value="Next" title="Next"" & @CRLF & _
"class="btn btn-link" type="submit"/>" & @CRLF & _
"" & @CRLF & _
"<input type="submit" name="daily" value="Next" title="Next"" & @CRLF & _
" class="btn btn-link"/>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")