using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<input[^>]*\s*(?=[^>]*type\s*=\s*('|""|)Submit\s*(\1))[^>]*\s*(?:value\s*=('|""|)Next\s*(\3))[^>]*>";
string input = @"<input name=""daily"" value=""Next"" title=""Next""
class=""btn btn-link"" type=""submit""/>
<input type=""submit"" name=""daily"" value=""Next"" title=""Next""
class=""btn btn-link""/>";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}