import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<input[^>]*\\s*(?=[^>]*type\\s*=\\s*('|\"|)Submit\\s*(\\1))[^>]*\\s*(?:value\\s*=('|\"|)Next\\s*(\\3))[^>]*>";
final String string = "<input name=\"daily\" value=\"Next\" title=\"Next\"\n"
+ "class=\"btn btn-link\" type=\"submit\"/>\n\n"
+ "<input type=\"submit\" name=\"daily\" value=\"Next\" title=\"Next\"\n"
+ " class=\"btn btn-link\"/>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}