$re = '/<input[^>]*\s*(?=[^>]*type\s*=\s*(\'|"|)Submit\s*(\1))[^>]*\s*(?:value\s*=(\'|"|)Next\s*(\3))[^>]*>/i';
$str = '<input name="daily" value="Next" title="Next"
class="btn btn-link" type="submit"/>
<input type="submit" name="daily" value="Next" title="Next"
class="btn btn-link"/>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);