const regex = /<input[^>]*\s*(?=[^>]*type\s*=\s*('|"|)Submit\s*(\1))[^>]*\s*(?:value\s*=('|"|)Next\s*(\3))[^>]*>/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<input[^>]*\\s*(?=[^>]*type\\s*=\\s*(\'|"|)Submit\\s*(\\1))[^>]*\\s*(?:value\\s*=(\'|"|)Next\\s*(\\3))[^>]*>', 'gi')
const str = `<input name="daily" value="Next" title="Next"
class="btn btn-link" type="submit"/>
<input type="submit" name="daily" value="Next" title="Next"
class="btn btn-link"/>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}