import Foundation
let pattern = #"<input[^>]*\s*(?=[^>]*type\s*=\s*('|"|)Submit\s*(\1))[^>]*\s*(?:value\s*=('|"|)Next\s*(\3))[^>]*>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
<input name="daily" value="Next" title="Next"
class="btn btn-link" type="submit"/>
<input type="submit" name="daily" value="Next" title="Next"
class="btn btn-link"/>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)