re = /<input[^>]*\s*(?=[^>]*type\s*=\s*('|"|)Submit\s*(\1))[^>]*\s*(?:value\s*=('|"|)Next\s*(\3))[^>]*>/i
str = '<input name="daily" value="Next" title="Next"
class="btn btn-link" type="submit"/>
<input type="submit" name="daily" value="Next" title="Next"
class="btn btn-link"/>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end