package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\$infusionsoft->contacts\(\)->addToGroup\(\s*(\$[^\s]+|\d+)\s*,\s*(\$[^\s]+|\d+)`)
var str = `$infusionsoft->contacts()->addToGroup($student['Id'], 1276);
$infusionsoft->contacts()->addToGroup($student[ 'Id' ],1660);
$infusionsoft->contacts()->addToGroup( $student[0] , 1660 );
$infusionsoft->contacts()->addToGroup($student , 1660 );
$infusionsoft->contacts()->addToGroup( 3131 , $dogc[1] );
$infusionsoft->data()->addToGroup($student['Id'], 1276);
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}