const regex = /\$infusionsoft->contacts\(\)->addToGroup\(\s*(\$[^\s]+|\d+)\s*,\s*(\$[^\s]+|\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\$infusionsoft->contacts\\(\\)->addToGroup\\(\\s*(\\$[^\\s]+|\\d+)\\s*,\\s*(\\$[^\\s]+|\\d+)', 'gm')
const str = `\$infusionsoft->contacts()->addToGroup(\$student['Id'], 1276);
\$infusionsoft->contacts()->addToGroup(\$student[ 'Id' ],1660);
\$infusionsoft->contacts()->addToGroup( \$student[0] , 1660 );
\$infusionsoft->contacts()->addToGroup(\$student , 1660 );
\$infusionsoft->contacts()->addToGroup( 3131 , \$dogc[1] );
\$infusionsoft->data()->addToGroup(\$student['Id'], 1276);
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}