use strict;
my $str = '$infusionsoft->contacts()->addToGroup($student[\'Id\'], 1276);
$infusionsoft->contacts()->addToGroup($student[ \'Id\' ],1660);
$infusionsoft->contacts()->addToGroup( $student[0] , 1660 );
$infusionsoft->contacts()->addToGroup($student , 1660 );
$infusionsoft->contacts()->addToGroup( 3131 , $dogc[1] );
$infusionsoft->data()->addToGroup($student[\'Id\'], 1276);
';
my $regex = qr/\$infusionsoft->contacts\(\)->addToGroup\(\s*(\$[^\s]+|\d+)\s*,\s*(\$[^\s]+|\d+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}