$re = '/\$infusionsoft->contacts\(\)->addToGroup\(\s*(\$[^\s]+|\d+)\s*,\s*(\$[^\s]+|\d+)/m';
$str = '$infusionsoft->contacts()->addToGroup($student[\'Id\'], 1276);
$infusionsoft->contacts()->addToGroup($student[ \'Id\' ],1660);
$infusionsoft->contacts()->addToGroup( $student[0] , 1660 );
$infusionsoft->contacts()->addToGroup($student , 1660 );
$infusionsoft->contacts()->addToGroup( 3131 , $dogc[1] );
$infusionsoft->data()->addToGroup($student[\'Id\'], 1276);
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);