import Foundation
let pattern = #"\$infusionsoft->contacts\(\)->addToGroup\(\s*(\$[^\s]+|\d+)\s*,\s*(\$[^\s]+|\d+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
$infusionsoft->contacts()->addToGroup($student['Id'], 1276);
$infusionsoft->contacts()->addToGroup($student[ 'Id' ],1660);
$infusionsoft->contacts()->addToGroup( $student[0] , 1660 );
$infusionsoft->contacts()->addToGroup($student , 1660 );
$infusionsoft->contacts()->addToGroup( 3131 , $dogc[1] );
$infusionsoft->data()->addToGroup($student['Id'], 1276);
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)