re = /\$infusionsoft->contacts\(\)->addToGroup\(\s*(\$[^\s]+|\d+)\s*,\s*(\$[^\s]+|\d+)/m
str = '$infusionsoft->contacts()->addToGroup($student[\'Id\'], 1276);
$infusionsoft->contacts()->addToGroup($student[ \'Id\' ],1660);
$infusionsoft->contacts()->addToGroup( $student[0] , 1660 );
$infusionsoft->contacts()->addToGroup($student , 1660 );
$infusionsoft->contacts()->addToGroup( 3131 , $dogc[1] );
$infusionsoft->data()->addToGroup($student[\'Id\'], 1276);
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end