import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\$infusionsoft->contacts\\(\\)->addToGroup\\(\\s*(\\$[^\\s]+|\\d+)\\s*,\\s*(\\$[^\\s]+|\\d+)";
final String string = "$infusionsoft->contacts()->addToGroup($student['Id'], 1276);\n"
+ "$infusionsoft->contacts()->addToGroup($student[ 'Id' ],1660);\n"
+ "$infusionsoft->contacts()->addToGroup( $student[0] , 1660 );\n"
+ "$infusionsoft->contacts()->addToGroup($student , 1660 );\n"
+ "$infusionsoft->contacts()->addToGroup( 3131 , $dogc[1] );\n"
+ "$infusionsoft->data()->addToGroup($student['Id'], 1276);\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}