using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^=(\(?([a-zA-Z]{1,10}[0-9]{1,10})\)?(\+|-|\*|/)?)+$";
string input = @"=A1+B2*(a3+R4-v2)+a1+r5";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}