re = /^=(\(?([a-zA-Z]{1,10}[0-9]{1,10})\)?(\+|-|\*|\/)?)+$/
str = '=A1+B2*(a3+R4-v2)+a1+r5'
# Print the match result
str.match(re) do |match|
puts match.to_s
end