const regex = /^=(\(?([a-zA-Z]{1,10}[0-9]{1,10})\)?(\+|-|\*|/)?)+$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^=(\\(?([a-zA-Z]{1,10}[0-9]{1,10})\\)?(\\+|-|\\*|\/)?)+$', '')
const str = `=A1+B2*(a3+R4-v2)+a1+r5`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}