package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^=(\(?([a-zA-Z]{1,10}[0-9]{1,10})\)?(\+|-|\*|/)?)+$`)
var str = `=A1+B2*(a3+R4-v2)+a1+r5`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}