import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^=(\\(?([a-zA-Z]{1,10}[0-9]{1,10})\\)?(\\+|-|\\*|/)?)+$";
final String string = "=A1+B2*(a3+R4-v2)+a1+r5";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}