# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/i:\d+;s:\d+:"([^"]*)";//gm;t' <<< "a:4:{i:0;s:4:\"a’\";i:1;s:6:\"abcdef\";i:2;s:5:\"abcde\";i:3;s:3:\"xyz\";}"