import re
regex = re.compile(r"i:\d+;s:\d+:\"([^\"]*)\";", flags=re.MULTILINE)
test_str = "a:4:{i:0;s:4:\"a’\";i:1;s:6:\"abcdef\";i:2;s:5:\"abcde\";i:3;s:3:\"xyz\";}"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)