// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)i:\d+;s:\d+:"([^"]*)";"#).unwrap();
let string = "a:4:{i:0;s:4:\"a’\";i:1;s:6:\"abcdef\";i:2;s:5:\"abcde\";i:3;s:3:\"xyz\";}";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}