import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "i:\\d+;s:\\d+:\"([^\"]*)\";";
final String string = "a:4:{i:0;s:4:\"a’\";i:1;s:6:\"abcdef\";i:2;s:5:\"abcde\";i:3;s:3:\"xyz\";}";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}