re = /i:\d+;s:\d+:"([^"]*)";/m
str = 'a:4:{i:0;s:4:"a’";i:1;s:6:"abcdef";i:2;s:5:"abcde";i:3;s:3:"xyz";}'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result