using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"i:\d+;s:\d+:""([^""]*)"";";
string substitution = @"";
string input = @"a:4:{i:0;s:4:""a’"";i:1;s:6:""abcdef"";i:2;s:5:""abcde"";i:3;s:3:""xyz"";}";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}