const regex = /i:\d+;s:\d+:"([^"]*)";/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('i:\\d+;s:\\d+:"([^"]*)";', 'gm')
const str = `a:4:{i:0;s:4:"a’";i:1;s:6:"abcdef";i:2;s:5:"abcde";i:3;s:3:"xyz";}`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);