using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?:[0-9]{2}[:\/,]){2}[0-9]{2,4}|am|pm)$";
string input = @"08/20/2014
10:04:27
pm
complet
vendor
per
mfg/recommend
08/20/2014
10:04:27
pm
complete";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}