$re = '/^(?:(?:[0-9]{2}[:\/,]){2}[0-9]{2,4}|am|pm)$/mix';
$str = '08/20/2014
10:04:27
pm
complet
vendor
per
mfg/recommend
08/20/2014
10:04:27
pm
complete';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);