// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mix)^(?:(?:[0-9]{2}[:\/,]){2}[0-9]{2,4}|am|pm)$").unwrap();
let string = "08/20/2014
10:04:27
pm
complet
vendor
per
mfg/recommend
08/20/2014
10:04:27
pm
complete";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}