const regex = /^(?:(?:[0-9]{2}[:\/,]){2}[0-9]{2,4}|am|pm)$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?:[0-9]{2}[:\\\/,]){2}[0-9]{2,4}|am|pm)$', 'gmi')
const str = `08/20/2014
10:04:27
pm
complet
vendor
per
mfg/recommend
08/20/2014
10:04:27
pm
complete`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}