re = /^(?:(?:[0-9]{2}[:\/,]){2}[0-9]{2,4}|am|pm)$/mix
str = '08/20/2014
10:04:27
pm
complet
vendor
per
mfg/recommend
08/20/2014
10:04:27
pm
complete'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end