import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:[0-9]{2}[:\\/,]){2}[0-9]{2,4}|am|pm)$";
final String string = "08/20/2014\n"
+ "10:04:27\n"
+ "pm\n"
+ "complet\n"
+ "vendor\n"
+ "per\n"
+ "mfg/recommend\n"
+ "08/20/2014\n"
+ "10:04:27\n"
+ "pm\n"
+ "complete";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}