import re
regex = re.compile(r"""
^(?:(?:[0-9]{2}[:\/,]){2}[0-9]{2,4}|am|pm)$
""", flags=re.MULTILINE | re.IGNORECASE | re.VERBOSE)
test_str = ("08/20/2014\n"
"10:04:27\n"
"pm\n"
"complet\n"
"vendor\n"
"per\n"
"mfg/recommend\n"
"08/20/2014\n"
"10:04:27\n"
"pm\n"
"complete")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")